Compatible Browsers for Collaborative Web UI

Please note that these requirements are for the New user interface and so do not apply to the Classic UI.

Browsers:  Internet Explorer 9-11 and the latest two versions Chrome, Firefox, Safari, and Microsoft Edge.

Note: Support for Internet Explorer 9 will end on May 31st, 2016.  Support for Internet Explorer 10 will end on on September 30th, 2016.  Microsoft ended support for these browsers on end user operating systems on January 12th, 2016. 

Flash version recommended: Flash is optional (required for upload in Internet Explorer versions prior to 10).  When used, we recommend always installing the latest version of Flash to protect against security vulnerabilities.

JDK version:  Java is optional (required for the Java Uploader).  When used, we recommend always installing the latest version of Java to protect against security vulnerabilities.

 

Was this article helpful?
8 out of 8 found this helpful
Have more questions? Submit a request

Comments

Featured Articles