Egnyte Help Desk

Egnyte unaffected FREAK SSL/TLS Vulnerability

3/9/15
 
Egnyte users are not affected by recently announced security flaw called FREAK. We have not supported export grade ciphersuites and we verified it in all nodes in all Datacenters.

Most major web browsers are safe against FREAK, however, two huge groups are at risk - Android users and Safari users. We encourage you to keep an eye for Android updates for OpenSSL which is vulnerable to CVE-2015-0204. Also as far as we know Apple is already working on a patch for Safari which will make you safe against the vulnerability while browsing websites which support export grade ciphers.
 
Sincerely,
Egnyte Security Team
Egnyte Community

Egnyte Community

Want to connect with other Egnyte users and our Egnyte team? Share ideas and ask questions in our Community.

Help Improve Egnyte

Every day we work hard to make Egnyte better with feedback from users to improve our products. Sign up to participate in Egnyte User Studies.